Training and Certifications
When and Where You Need Them

    Explore Our Class Formats

 

Please update your browser's security settings.
To maintain the highest security standards, we will be disabling support for browsers using TLS 1.0. Learn more and upgrade your browser here.

 

System Requirements

To access the United Academy website you must be connected to the internet.

CPU

Core 2 Duo 2 Ghz, or greater. Note: Microsoft recently removed support for Windows XP so we recommend updating to Windows 7 or 10.

Memory (RAM)

2 GB or greater

Internet Connection

A minimum download connection speed of 1.8 Mbps is recommended for courseware streaming.

Monitor Resolution

1024 x 768 or higher recommended

Web Browsers

Internet Explorer 9 or higher (Note: Microsoft is no longer supporting versions 8,9 and 10 so we recommend you update to the latest version)

Mozilla Firefox 17.0 or higher

Google Chrome 23.0 or higher

Apple Safari X or higher

PDF

Adobe Acrobat Reader 8 or higher

Online Courseware System Requirements

United Academy’s online courses use a variety of technologies and have different requirements. In addition to the requirements above, each online course has a system check which tests your system to ensure compatibility. If required, you can download the required Flash and Unity plug-ins below.

Online Courses
Test your device to see if it meets the minimum requirements. Some of these courses are mobile friendly and are noted as such on the product page. 
Run Test

Blended Learning Courses
Test your computer to see if it meets the minimum requirements including support for Flash and Unity plug-ins.
Run Test

 

Note: Google Chrome recently removed support for the Unity plug-in which is required for the games in our blended learning courses. We recommend using one of the other browser's listed above.

Adobe Flash